开启辅助访问 切换到窄版

error: Your version of OpenSSL is not compatible with this version of tcnative

[复制链接]
作者:hanhongwen 
版块:
Linux Linux-问题解决方案 发布时间:2017-8-24 17:03:52
5020

管理员

积分
11016
QQ
hanhongwen 发表于 2017-8-24 17:03:52 | 显示全部楼层 |阅读模式

问题原因:
安装tomcat-native的时候,编译过程中报的一个错误,说是版本不对,需要更换新版本
报错如下图
121.jpg


查看当系统使用版本
[root@safehourse70 native]# openssl version -a
123.jpg




解决办法:
1、先去openssl官网下载一个最新版本
https://www.openssl.org/source/
[root@safehourse70 ~]# wget https://www.openssl.org/source/openssl-1.1.0f.tar.gz


2、解压,编译安装
2.1 解压
[root@safehourse70 ~]# tar -xf openssl-1.1.0f.tar.gz
[root@safehourse70 ~]# cd openssl-1.1.0f

2.2 安装
[root@safehourse70 openssl-1.1.0f]# ./config --prefix=/usr/local/openssl
[root@safehourse70 openssl-1.1.0f]# ./config -t

[root@safehourse70 openssl-1.1.0f]# make && make install


更新完openssl再次安装tomcat-native没有报错


以上就是安装openssl的过程,祝你成功
    15561578755
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表