开启辅助访问 切换到窄版

Ubuntu系统使用aptitude安装系统软件解决依赖包安装问题

[复制链接]
作者:hanhongwen 
版块:
Linux Linux-问题解决方案 发布时间:2020-1-8 12:40:57
2630

管理员

积分
14807
QQ
hanhongwen 发表于 2020-1-8 12:40:57 | 显示全部楼层 |阅读模式
1、问题原因:在安装软件我包的时候提示由于依赖原因无法安装软件,安装完依赖包还是无法继续安装,如下图提示
  1. # apt-get -y install tigervnc-standalone-server tigervnc-xorg-extension tigervnc-viewer tigervnc-common
复制代码

2.png

2、解决方案:安装并使用aptitude命令进行安装并解决依赖问题
  1. # apt-get -y install aptitude
  2. # aptitude -y install tigervnc-standalone-server tigervnc-xorg-extension tigervnc-viewer tigervnc-common
复制代码

3.png

3、aptitude常用命令如下
  1. aptitude update          更新可用的包列表
  2. aptitude upgrade          升级可用的包
  3. aptitude dist-upgrade        将系统升级到新的发行版
  4. aptitude install pkgname       安装包
  5. aptitude remove pkgname        删除包
  6. aptitude purge pkgname         删除包及其配置文件
  7. aptitude search string        搜索包
  8. aptitude show pkgname         显示包的详细信息
  9. aptitude clean            删除下载的包文件
  10. aptitude autoclean         仅删除过期的包文件
复制代码



以上为Ubuntu系统使用aptitude安装系统软件解决依赖包安装问题的简单操作步骤及解决方案,祝你成功


    15561578755
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表